FANDOM


BYOND Environment This page contains an entry from the official DM Reference.

This macro indicates the version of the compiler. This could be useful when distributing code that uses new language features that would not compile in older compilers.

ExampleEdit

#if DM_VERSION < 230
#error This compiler is too far out of date!
#endif

See alsoEdit


preprocessor
directives #define | #error | #if | #ifdef | #ifndef | #include | #undef | #warn
macros DM_VERSION | __FILE__ | __LINE__ | __MAIN__
definitions DEBUG | FILE_DIR